41 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Openwrt x86 установка на pc

OpenWrt Project

User Tools

Site Tools

Sidebar

Table of Contents

OpenWrt on x86 hardware aka PC or Servers

OpenWrt can of course run in normal PC or server hardware, and take advantage of the much more powerful hardware the x86 (Intel/AMD) architecture can offer.

Note: For UEFI bootable OpenWrt image see OpenWrt on UEFI based x86 systems

Download disk images

Go here, choose the release version, then click on target and then on x86. You will see different targets.

There are multiple targets for x86 OpenWrt, some are targeted at old or specific hardware and their build defaults may not be suit modern x86 hardware.

Now you will see different files offered, the following two are disk images you can download and use:

Hardware Support

All images support basic video output (screen text terminal), so you can connect a screen to the device’s video ports and see it boot up.

No image supports keyboard and mouse so the only way to communicate is through Ethernet or through the device’s serial port.

To communicate through a PC serial port you will need a “null-modem” aka “crossed” serial cable to connect the device’s serial port to your PC’s serial port.

To be able to connect to your device, the image must support the Ethernet hardware.

The 64bit image supports Intel and Realtek Ethernet chipsets. These are the kmods installed by default: kmod-button-hotplug kmod-e1000e kmod-e1000 kmod-r8169 kmod-igb

The Generic and Legacy images support Intel, Realtek, Via and some other ethernet chipsets. These are the kmods installed by default: kmod-button-hotplug kmod-e1000e kmod-igb kmod-3c59x kmod-e100 kmod-e1000 kmod-natsemi kmod-ne2k-pci kmod-pcnet32 kmod-8139too kmod-r8169 kmod-sis900 kmod-tg3 kmod-via-rhine kmod-via-velocity

The Geode images support Geode hardware so as long as you have a Geode-based board you should be fine.

Installation

The installation is just writing a raw disk image on a USB flash drive or USB SDcard reader with SDcard (recommended) or in a Sata hard drive or SSD from your PC, then connecting this drive to the target device and make it boot from that drive.

Installation procedure differs depending from what PC you are using to write the raw disk image from, mostly because of different tools you have to use.

WARNING: writing raw image files DELETES the content of the drive you write them on, be sure that you are not deleting anything important, and that you have selected the right drive.

Windows

If you are using a Windows PC, you will need a program to extract the raw disk image from the compressed archive you downloaded.
Then you will need to open the raw image file with a program that can write it on the drive you want to install OpenWrt on.

A good free and opensource archiver program you can use is 7zip.

A good free and opensource raw disk image writer program you can use is Win32 Disk Imager , there is also Etcher .

MacOS

Same as with Windows.

The archiver program recommended by 7zip on MacOS is Keka

A good free and opensource raw disk image writer program you can use is Etcher .

Linux

Linux users will probably know how to do this better on their own already, but I’ll say it anyway.

Extract the image file from the archive. Most sane distros will let you do so by rightclick and then select “extract”, or you will have to open up your graphical archive manager and do it from there. From the terminal it is done by gzip -d openwrt-18.06.1-x86-64-combined-squashfs.img.gz .

Then write the image file you extracted to the drive you want to install OpenWrt in. Many distros include a disk image writer application already (also, “Gnome Disks” application allows you to do this). From the terminal, detect how is called (sda, sdb, sdc, etc) the drive you want by writing sudo blkid or sudo lsblk and then write the image with good old dd tool dd if=openwrt-18.06.1-x86-64-combined-squashfs.img of=/dev/sdX where sdX is the name of the drive you want to write the image on.

Partition Layout

The x86 image is using the following partition layout (as seen from inside of the device):

Any additional space in the device is unallocated.

Resizing partitions

This is possible only if you have chosen the combined-ext4.img.gz type of image, and currently due to technical limitations you can’t just resize the ext4 partition online (while it is mounted) so you will need to install OpenWrt on another drive to use it to perform the following operations. Also using a Linux system (either from a VM or actually installed in a PC) will of course work.

an example fdisk operation on a 8GB flash drive

Compiling your own image with larger partition size

The symbol that sets the partition size is called TARGET_ROOTFS_PARTSIZE, and can be changed by menuconfig by going in the image settings.

Читать еще:  Ошибка 0xc00000e9 при установке Windows 7

OSBoy notes.

Записки обо всём.

Установка OpenWrt на виртуальную машину

Настало время опробовать свежий релиз OpenWRT 15.05 Chaos Calmer. А заодно я решил затестить, каково это — OpenWRT на x86 архитектуре, т.к. Линукс под рукой время от времени бывает нужен — для всяких экспериментов, ну или, хотя бы, флешку отформатировать для роутера. 🙂 Раньше я для этого использовал ноут с ArchLinux-ом. Но ноут у меня накрылся, да и Arch я разлюбил, после того как он на systemd перешёл. как то лень его фактически с нуля по новой осваивать! Зато для этих целей прекрасно подойдёт виртуалка с уже полюбившимся мне OpenWRT!

Подготовка ПО
Качаем последнюю стабильную версию VirtualBox (на момент написания статьи — 5.0.6) и соответствующую версию Extension Pack для него. Устанавливаем VirtualBox и Extension Pack. В моём случае — на компьютере установлена Windows 7 64bit — она и будет использоваться как Хост-ОС.
Качаем образ OpenWRT. Тут выбираем нужный релиз, затем архитектуру x86 (либо x86/64, как я, собственно, и сделал в данном случае) и, наконец, нужный образ (в данном случае — openwrt-15.05-x86-64-combined-ext4.img.gz). Если есть готовый образ для VirtualBox (.vdi) — скачиваем его. Если же доступен только raw образ (.img.gz), то его потребуется переконвертировать в совместимый с VirtualBox формат. Для этого воспользуемся встроенным в VirtualBox конвертором. В папке с установленной VirtualBox создаём текстовый файл с расширением .bat или .cmd следующего содержания: «%

dp0VBoxManage.exe» convertfromraw —format VDI %1 «%

dpn1.vdi»
pause Затем распаковываем образ из скачанного архива и перетаскиваем его на созданный ранее скрипт. Полученный .vdi образ можно подключать к Виртуальной машине.

Создание виртуальной машины (ВМ)
Запускаем VirtualBox и жмём «Создать». Задаём имя, тип и версию гостевой системы:

На этапе подключения жёсткого диска выбираем «Использовать существующий виртуальный жёсткий диск» и подключаем наш .vdi образ с OpenWRT:

Затем Выбираем созданную ВМ и жмём «Настроить». На вкладке «Сеть» настраиваем сетевой интерфейс для связи ВМ с внешним миром. Мой хост-компьютер подключен к домашней сети и интернет через роутер. Поэтому удобнее всего для ВМ будет использовать тип подключения «Сетевой мост». Таким образом ВМ будет выглядеть в сети как отдельное устройство: будет иметь возможность общаться с другими устройствами в домашней сети (включая хост-компьютер), выходить в интернет, получать от роутера IP адрес по DHCP и т.д.

Здесь «Realtek PCIe GBE Family Controller» — это физический интерфейс хост-машины, подключенный к роутеру, через который будет организован «сетевой мост».

На вкладке «COM-порты» нужно обязательно поставить галочку «Включить последовательный порт», иначе OpenWRT не сможет запуститься.

Запуск ВМ и настройка сети
Запускаем созданную виртуальную машину. После окончания процесса загрузки нажимаем Enter — станет доступна консоль OpenWRT.

Создаём пароль для root: passwd По умолчанию OpenWRT использует на lan интерфейсе статический адрес 192.168.1.1 . Чтобы настроить ВМ для работы в нашей домашней сети, редактируем конфиг: vi /etc/config/network Так как в моей домашней сети устройства получают адреса от роутера по DHCP, приводим конфиг примерно к такому виду: config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option ifname eth0
option proto dhcp Применяем настройки сети: /etc/init.d/network reload Чтобы ВМ получала от роутера фиксированный IP адрес, добавляем MAC-адрес виртуального адаптера в список постоянных аренд в настройках DHCP сервера на роутере и присваиваем ему нужный IP.

Также отмечу, что я в настройках ВМ включил два сетевых интерфейса: один — для связи с домашней сетью и интернетом, второй — для других целей. Оба — в режиме сетевого моста. OpenWRT по умолчанию определила первый интерфейс (eth0) как lan со статическим адресом 192.168.1.1, второй (eth1) — как wan с получением адреса по DHCP. Таким образом доступ из виртуалки в домашнюю сеть и интернет получился сразу «из коробки». Однако по умолчанию фаервол OpenWRT запрещает подключение к ней по SSH и к вэб-интерфейсу по http «извне» — то есть через wan интерфейс. Но так как виртуалка будет находиться в моей домашней сети, я просто переназначил интерфейсы lan и wan для удобства работы: config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’option netmask ‘255.0.0.0’

config interface ‘wan’
option ifname ‘eth0’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.1.10’
option netmask ‘255.255.255.0’
option ip6assign ’60’

config interface ‘lan’
option ifname ‘eth1’
option proto ‘dhcp’

В VirtualBox версии 5.0.4 у меня наблюдался такой баг: виртуальные (гостевые) машины видели по сети роутер, друг друга, выходили в интернет, НО не видели хост-машину, так же как и хост-машина не видела гостевые! Баг вылечился обновлением VirtualBox до версии 5.0.6.

Расширение дискового пространства
Ну и теперь, когда у нашей ВМ есть выход в интернет, можно устанавливать все необходимые пакеты, например: opkg update
opkg install nano mc В скачанном образе OpenWRT корневой раздел размером около 48мБ. Этого вполне достаточно для установки пакетов первой необходимости и выполнения многих задач. Однако, если нам этого недостаточно, то увеличим виртуальный жёсткий диск. В VirtualBox вроде бы для этого есть специальный инструмент и можно в принципе воспользоваться им. Но я сделал иначе.
В настройках виртуальной машины подключим ещё один виртуальный жёсткий диск. Выбираем «Создать новый диск», затем задаём его название, выбираем нужный размер и формат хранения:

Загружаем нашу виртуалку и проверяем, что система увидела второй диск: ls -la /dev | grep sd
brw-r—r— 1 root root 8, 0 Oct 8 20:22 sda
brw-r—r— 1 root root 8, 1 Oct 8 20:22 sda1
brw-r—r— 1 root root 8, 2 Oct 8 20:22 sda2
brw-r—r— 1 root root 8, 1 Oct 8 20:22 sdb Видим, что второй диск определился как /dev/sdb. Теперь просто копируем первый диск на него утилитой dd: dd if=/dev/sda of=/dev/sdb Останавливаем ВМ, удаляем из неё первый диск и грузимся со второго, оставшегося (теперь он уже станет /dev/sda). Можем убедиться, что диск у нас теперь стал действительно такого размера, какой мы задали, например утилитой cfdisk: cfdisk /dev/sda Однако видим, что наш корневой раздел sda2 так и остался размером 48мБ, а остальное место на диске осталось неразмеченным. Поэтому качаем LiveCD с утилитой GParted, подключаем его к виртуальному CD-приводу нашей машины, и загружаем с него виртуалку. Ну а дальше — дело техники: запускаем GParted, выбираем раздел /dev/sda2 и растягиваем его на всё неразмеченное пространство диска. В конце жмём «применить» («Apply»), и выключаем машину. Вот и всё, теперь можно извлечь образ из виртуального CD-привода и снова загрузить виртуалку с жесткого диска. Проверяем результат: df -h
Filesystem Size Used Available Use% Mounted on
rootfs 7.9G 13.7M 7.9G 0% /
/dev/root 7.9G 13.7M 7.9G 0% /
tmpfs 122.6M 52.0K 122.6M 0% /tmp
tmpfs 512.0K 0 512.0K 0% /dev

Читать еще:  Ошибка сети или сим карты что делать?

Установка OpenWrt в VirtualBox

Oracle VM VirtualBox — бесплатная, виртуальная машина для операционных систем Windows, Linux, FreeBSD, Mac OS X и других.

Установка VirtualBox

Идём на официальный сайт VirtualBox, скачиваем программу для своей операционной системы и устанавливаем.

Установка предельно простая. Для Win — будет .exe-файл, для Linux — готовый .deb-пакет, а для Mac — .dmg-пакет.

Выбор образа OpenWrt

Нам нужен образ для платформы x86. Я устанавливал версию Attitude Adjustment 12.09.
Отправляемся в официальный репозиторий и скачиваем .vdi-файл (openwrt-x86-generic-combined-ext4.vdi).

Если Вы хотите использовать другой образ, а в репозитории нет файла .vdi, то можно сконвертировать любой .img-файл.

Скачиваем нужный .img-файл в папку VirtualBox и следуем инструкции:

Для Win.

Создайте в папке VirtualBox текстовой файл convert.bat со следующим содержанием:

Перетащите скачаный .img-файл на файл convert.bat. Всё готово, образ можно подключать к виртуалке.

Для Linux.
Скачайте .img-файл в домашнюю папку и дайте в терминале команду:

Всё готово, образ можно подключать к виртуалке.

Установка OpenWrt в VirtualBox

Запускаем VirtualBox и нажимаем кнопку Создать

Имя — придумываем любое.
Тип — выбираем Linux.
Версия — Linux 2.6/3.x(32bit).
Нажимаем кнопку Вперёд

Оставляем как есть и жмём Вперёд

Выбираем раннее скаченый файл (openwrt-x86-generic-combined-ext4.vdi) и нажимаем Создать

Настройка

Нажимаем Настроить

Выбираем пункт Сеть

Тип подключения — выбираем Сетевой мост
Предполагается что компьютер подключён к роутеру.

Далее выбираем пункт COM-порты

Ставим галочку «Включить последовательный порт» и жмём ОК.
Это обязательно, иначе работать не будет.

Машина настроена и готова к запуску.

Запуск

Нажимаем Запустить

Ждём 4 секунды или нажимаем Enter

Загрузка остановится на таком экране:

Нажимаем Enter и видим:

Всё готово, теперь установим пароль Администратора (root).
Для этого вводим команду:

Будет предложено ввести новый пароль для root, придумываем и записываем на бумажку!
Вводим и нажимаем Enter. Внимание! Символы отображаться не будут!

Если Вы введёте слишком простой пароль, то роутер предупредит об этом:

Если надёжность пароля не критична, то просто продолжайте, если нет, то нажмите два раза Enter, венитесь к команде passwd и придумайте пароль посложнее.

Система попросит повторить пароль:

Вводим и нажимаем Enter. Внимание! Символы отображаться не будут!

Если всё прошло удачно, система ответит:

Всё готово, остаётся настроить сеть OpenWrt.

Предполагается что компьютер подключён к роутеру, который подключён к интернету, имеет адрес 192.168.1.1 и раздаёт адреса в диапазоне 192.168.1.2 — 254.
Если у Вас другая подсеть, то делайте всё что написано ниже, с учётом Вашего адресного пространства.

Редактируем файл в соответствии с картинкой:

Для этого нажимаем символ «i».
Вносим изменения.

Нажимаем Esc.
Вводим последовательно символы :wq (: w-сохранить q-выйти)
Нажимаем Enter.
Файл отредактирован.

Перегружаем командой reboot.

После перезагрузки проверяем сеть командой:

Если ping есть, то интернет настроен. Нажмите Ctrl + z для выхода.

Если нет, то проверяем настройки файла /etc/config/network

Можно подключаться к виртуалке по ssh.

Обновляем репозиторий OpenWrt командой:

Должно получится как на рисунке.

Дальше можно работать с OpenWrt. Я например первым делом устанавливаю Midnight Commander.
Команда для установки:

Для выхода из mc введите:

Выключается машина командой poweroff:

В web-интерфейс можно зайти по адресу 192.168.1.65

На этом всё.

Обсудить на форуме.

Мой дневник

записная книжка на все случаи хизни

OpenWRT x86

или как сделать wifi-рутер из старого нетбука

OpenWRT – свободное ПО для рутеров на базе Linux. Плюсы очевидны: никаких подводных камней, поддержка сообществом, куча возможностей… Но есть один минус – перешивать живой рабочий рутер как-то боязно. Потеряешь связь с тырнетом – сложно будет откатиться.

Поэтому я решил поэкспериментировать с версией для x86 на стареньком нетбуке (Acer Aspire One), подключить его в качестве рутера, а уже потом ковырять собственно рутер. Да и опыт на x86 пригодится.

Итак:
— домашняя сеть wifi уже есть, надо заменить рутер на наш нетбук.

Термины:
нетбук – тот что станет рутером,
комп – наш рабочий комп, где будем создавать флешку для нетбука (linux, разумеется =))
/dev/sdc – так наш комп видит usb-флешку

– подключаем нетбук к существующему рутеру шнурком ethernet
– скачиваем на комп образ openwrt-x86, например https://downloads.openwrt.org/chaos_calmer/15.05/x86/generic/openwrt-15.05-x86-generic-combined-ext4.img.gz
– распаковываем (gzip -d )
– заливаем полученный img на флешку, просто dd if= of=/dev/ (sudo если нужно, не промахнитесь с именем флешки!)
– монтируем второй раздел флешки (/dev/ ), надо подправить настройки сети:
– в /etc/config/networkconfig:
interface ‘lan’ -> option ipaddr ‘192.168.0.2’ Network->DHCP…->DNS forwardings->192.168.0.1 (наш старый рутер)
или route add default gw 192.168.0.1 (пропадает при рестарте сети?)
– добавляем dns: веб или echo “nameserver 8.8.8.8” >>/etc/resolv.conf


– проверяем работу: ping http://www.google.com =)

Wifi:
изначально модулей для wifi нет в наборе, нуджно поставить со всеми зависимостями. собственно ради чего мы и подключили роутер к сети.

ставить можно как по ssh так и через http
в моем случае ищу пакет для чипа ath5k.
– заходим на https://downloads.openwrt.org/chaos_calmer/15.05/x86/generic/packages/base/
– находим https://downloads.openwrt.org/chaos_calmer/15.05/x86/generic/packages/base/kmod-ath5k_3.18.20+2015-03-09-3_x86.ipk
– ставим opkg install kmod-ath5k_3.18.20+2015-03-09-3_x86.ipk (либо вводим kmod-ath5k_3.18.20+2015-03-09-3_x86.ipk в поле веб-морды System->Software->Download and install package
– аналогично ставим: wireless-tools_29-5_x86.ipk (iwconfig итп)
– для зaщиты WPA2/PSK ставим hostapd-mini
– настраиваем wifi-адаптер в веб-морде, networks->wifi->add, добавляем WPA2 в Advanced (там все логично)

Читать еще:  Что нужно сделать после установки Windows 10?

Затем нужно немного подумать и перенастроить LAN на wifi, а WAN – на eth0. Должно получиться так:

(изначально eth0 был включен в LAN, чтобы был удобный доступ к консоли и веб-морде)

собственно и все. теперь буду проверять.

UPD: оказалось это всего лишь начало. У меня beeline и l2tp, так что танцы с бубном продолжаются. Когда настрою – будет отдельный пост.

Самая быстрая установка Linux в моей жизни

Последнее время ищу быстрое, дешёвое, простое, а главное надёжное решение для сервера. Mele пока отпала из-за геммороя с компиляцией (надо много времени чтобы разобраться, а его нет 🙁 ). В результате пробую разные решения. Остановился я на OpenWRT, как на оси, которую я уже обмусолил со всех сторон, и которую я могу легко собрать и разобрать, дописав нужные штуки. (Я лукавлю 😉 ).

Сначала попробовал востановить тот самый роутер, который у меня так и никто и не забрал

После перешивки на OpenWRT заработали даже все порты, в т.ч. и WAN. Не работает правда первый лан. Попробовал туда даже скомилять свою програмку — всё работает. Но смутило подглючивание и потери сети. В общем, штука оказалась не очень надёжная. Годится только для лёгких опытов.

Благодаря многоуважаемому камраду goodic у мну появилась промышленная мамка на х86 архитектуре. Самое кошерное, она может работать от CF! Т.е. есть штатный разъём. Шикарно, у меня как раз завалялась карточка на 128 мегабайт!
Итак, самая быстрая установка Linux. Занимает меньше минуты, считая скачивание образа 🙂
Качаем OpenWRT отсюда http://downloads.openwrt.org/backfire/10.03.1/x86_generic/ . Я взял openwrt-x86-generic-combined-jffs2-64k.img. После чего вставляем карту в карт ридер и чистим её (тупо забиваем нулями):

/Загрузки$ sudo dd if=/dev/zero of=/dev/sdc bs=65535
dd: запись «/dev/sdc»: На устройстве кончилось место
1957+0 записей считано
1956+0 записей написано
скопировано 128188416 байт (128 MB), 40,5104 c, 3,2 MB/c

И после чего записываем скромные семь метров линуха:

/Загрузки$ sudo dd if=openwrt-x86-generic-combined-jffs2-12 8k.img of=/dev/sdc
14255+1 записей считано
14255+1 записей написано
скопировано 7298564 байта (7,3 MB), 6,59664 c, 1,1 MB/c

Вставляем карточку в плату:

Настраиваем загрузку с этого харда, и грузимся. После первичных настроек получаем расово чистую ОпенВРТ

Это всё выводится чере VGA. Осталось настроить сетку (там зачем-то сделан никому не нужный бридж) и доставить нужные пакеты. Единственное мы с sevasat (тоже владелец такой мамки с опенврт) не поняли, можно ли поставить иксы :). Я знаю, что кощунственна мысль OpenWRT с иксами, но ведь забавно ;))).

Благодарю goodic за железки и посильную помощь, камрада sevasat за доставку и идеи, а так же за классный вечер

Установка и настройка Openwrt

Openwrt — даже не прошивка, а операционная система linux для роутеров. Причин, для того, что бы ваш роутер был под управлением Openwrt много. Ведь перед вами хоть и урезанная, но система linux, с возможностью установки пакетов (приложений). Помните, перепрошивка роутера в openwrt лишает вас гарантии. Все действия, которые вы выполняете со своим роутером — вы делаете на свой страх и риск.

В первом повествовании не будем вдаваться во многие тонкости. Рассмотрим, как прошить роутер и настроить сеть через веб-интерфейс на примере TP-Link TL-WR740N v.5.

Установка и настройка Openwrt

Шаг 1. Подготовка и прошивка

И так, первый шаг: заходим в админку роутера, смотрим модель и версию:

Далее идём на сайт OpenWrt https://openwrt.org/toh/views/start , выбираем Table of Hardware: Standard, all devices тут же можно посмотреть техническую информацию об этом роутере и о любых других, поддерживаемых:

Переходим на страницу нашего устройства, смотрим версию устройства и качаем ту прошивку, в которой присутствует слово factory. Прошивка Sysupgrade нужна для обновления уже установленной системы:

Скачали, в веб интерфейсе нашего устройства нажмите выберите файл. Выбираем то, что скачали, затем нажмите Обновить:

Роутер прошивается.. После прошивки — веб-интерфейс будет доступен по http://192.168.1.1

Шаг 2. Первоначальная настройка

Рекомендую сразу установить пароль и выбрать интерфейс «lan» для подключения по SSH:

Шаг 4. Настройка PPPOE

Теперь настроим подключение к интернету. Если ваш провайдер раздаёт интернет по DHCP, то этот шаг мы пропустим. По умолчанию WAN настроен на DHCP client. Если же pppoe, то идем далее:

Переходим в Network -> Interfaces -> Add new interface. Задаём имя интерфейса, протокол (PPPoE). Cover the following interface выбираем тот, который с wan. Вообще, в моём случае в роутере есть свич — eth0.1 и отдельно адаптер ethernet — eth1. В некоторых случаях нет адаптера, есть только свич eth0 и он разделен вланами — eth0.1 будет wan, а eth0.2 свич.

Нажав Submit мы попадаем далее, здесь нужно указать логин/пароль от PPPoE:

Не применяя настроек, переходим в Firewall Settings и выбираем зону WAN. Сохраняем, применяем.

Если все сделано правильно, то, перейдя в Network -> Interfaces видим, что наш pppoe подключился. Проверяем интернет, должен работать.

Шаг 5. Настройка WiFi

По умолчанию в Openwrt выключен WiFi, что бы включить, переходим в Network -> Wireless -> Edit:

Тут можно выбрать канал, на котором будет работать наша Wi-Fi сеть, либо оставить auto, тогда канал будет сам выбираться, в зависимости от загруженности.

  • Режим работы (mode) — выбираем Access Point (точка доступа), о других режимах, мы поговорим в следующих статьях.
  • ESSID — имя сети Wi-Fi.

Далее перейдите на вкладку Wireless Security:

  • Encryption — WPA2-PSK.
  • Key — желаемый пароль Wi-Fi.

Не рекомендуется ставить пароль просто из 8 цифр, такой пароль очень уязвим!После всех настроек нажимаем Enable.

На этом пока всё. В дальнейших статьях мы рассмотрим конфигурационные файлы, логи, доступ через SSH, переназначение одного из LAN портов на WAN и так далее.

Ссылка на основную публикацию
Статьи c упоминанием слов:
Adblock
detector